Report Builder Inaccessible

Incident Report for Explo Status

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 21:20 UTC

Identified

We've identified an issue where viewing reports causes the page to crash - we have identified the fix and it should be out shortly
Posted Apr 23, 2025 - 20:53 UTC
This incident affected: Explo Report Builder.