Degraded performance across Explo app and Embeds

Incident Report for Explo Status

Resolved

Explo service is fully operational. We're continuing to instigate the root cause to avoid issues going forward.
Posted Oct 03, 2025 - 21:05 UTC

Monitoring

We've addressed resourcing constraints causing issues and are actively monitoring for any additional issues.
Posted Oct 03, 2025 - 21:02 UTC

Investigating

We are currently investigating this issue.
Posted Oct 03, 2025 - 20:58 UTC
This incident affected: Explo Dashboards, Explo Report Builder, Exports: Email delivery, Exports: Image and PDF format and Legacy Query Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports).