Intermittent Access for Snowflake Users

Incident Report for Explo Status

Resolved

Snowflake connectivity issues have been resolved and they have acknowledged that Explo's IPs were incorrectly blocked.
Posted Jul 09, 2025 - 01:20 UTC

Identified

We have identified that Snowflake incorrectly categorized certain Explo IPs under their Malicious IP Protection feature and we are working with them to re-enable access.
Posted Jul 08, 2025 - 23:45 UTC

Update

We've spoken with Snowflake and they are currently investigating the issue on their end. We should have an update from them in an hour and will share here accordingly.
Posted Jul 08, 2025 - 22:14 UTC

Update

We are continuing to investigate this issue.
Posted Jul 08, 2025 - 20:34 UTC

Investigating

We are currently experiencing a service issue with Snowflake connections. Starting at 3:20pm ET our IP Address's for database connections (3.219.104.199 and 35.175.85.18) appear to be blocked by Snowflake resulting in intermittent access to customer data on Explo. We'll have an update for you shortly on when we expect the connection to be restored, we are currently in contact with Snowflake on this matter.
Posted Jul 08, 2025 - 20:25 UTC
This incident affected: Explo Dashboards, Explo Report Builder and Data Connector Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports).