Latency issues due to higher than usual traffic to Explo application

Incident Report for Explo Status

Resolved

Marking as resolved given the previous update.
Posted Jul 10, 2025 - 20:39 UTC

Update

We disabled some settings with our intermediary provider given their partial outage. For Explo users, things should be back to normal. We are in communication with them and will re-enable once they’ve resolved.
Posted Jul 10, 2025 - 20:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 10, 2025 - 20:37 UTC

Identified

We have identified some issues with an intermediary provider causing degraded performance. We're actively monitoring the issue and evaluating potential resolutions.
Posted Jul 10, 2025 - 20:18 UTC

Investigating

We are currently investigating the issue but are experiencing higher than usual load times.
Posted Jul 10, 2025 - 20:04 UTC
This incident affected: Explo Dashboards, Explo Report Builder and Data Connector Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports).