Global Explo outage due to CDN issues

Incident Report for Explo Status

Resolved

Cloudflare has confirmed the issue is resolved.
Posted Nov 18, 2025 - 14:50 UTC

Update

Cloudflare is continuing to mitigate the service disruption.
Posted Nov 18, 2025 - 14:07 UTC

Investigating

Cloudflare has confirmed a global infrastructure outage. Since cloudflare serves all of Explo's traffic we're experiencing high rates of load failures and slow performance. More at https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 11:50 UTC
This incident affected: Explo Dashboards, Explo Report Builder, Exports: Email delivery, Exports: Image and PDF format, GovCloud Data Connector, Legacy Query Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports), and Data Connector Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports).