Issues Sending Scheduled Report Builder Emails

Incident Report for Explo Status

Resolved

We have deployed the fix and are monitoring for further issues.
Posted Feb 26, 2025 - 15:00 UTC

Investigating

We are investigating reports that scheduled report builder emails are not being received by end users
Posted Feb 24, 2025 - 16:00 UTC
This incident affected: Exports: Email delivery.