Degraded Query Execution Performance

Incident Report for Explo Status

Resolved

Marking this now as resolved.
Posted Oct 21, 2025 - 00:59 UTC

Update

We have confirmed things have been resolved and AWS is back to being fully operational.
Posted Oct 21, 2025 - 00:58 UTC

Update

AWS has indicated that their services are starting to slowly recover. We are seeing that on our side as well. Updating the impact of this to minor, but will not fully resolve until AWS has given the all clear.
Posted Oct 20, 2025 - 21:57 UTC

Update

No change from last status update. We continue to monitor closely, and will provide updates as we know more.
Posted Oct 20, 2025 - 18:31 UTC

Update

We are experiencing issues with query execution due to the ongoing AWS outage. We will continue to monitor the situation and provide updates as we know more.
Posted Oct 20, 2025 - 16:43 UTC

Investigating

We are experiencing issues with query execution due to the ongoing AWS outage. We will continue to monitor the situation and provide updates as we know more.
Posted Oct 20, 2025 - 05:00 UTC
This incident affected: Data Connector Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports).