Issue downloading CSVs and PDFs
Incident Report for Explo Status
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 16:55 UTC
Identified
The issue has been identified and should be resolved within the next 30 minutes.
Posted Nov 18, 2022 - 16:22 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2022 - 15:29 UTC
This incident affected: Embedded Dashboards.