Degraded Data Querying

Incident Report for Explo Status

Resolved

We have resolved this incident. And data querying is back to normal.
Posted Sep 30, 2025 - 18:28 UTC

Identified

The issue has been identified and the fix is being rolled out.
Posted Sep 30, 2025 - 18:20 UTC
This incident affected: Data Connector Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds).