Intermittent loading issues on the Explo Application

Incident Report for Explo Status

Resolved

This Incident has been resolved
Posted Jun 02, 2026 - 15:09 UTC

Investigating

We are currently investigating an issue loading the Explo Application
Posted Jun 02, 2026 - 14:50 UTC
This incident affected: Explo Dashboards and Explo Report Builder.