Degraded BigQuery Performance

Incident Report for Explo Status

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 02:08 UTC

Update

Google Cloud has now marked this as resolved.
Posted Jun 13, 2025 - 02:08 UTC

Monitoring

Google Cloud has now updated their status page: https://status.cloud.google.com/

We will continue to monitor. To reiterate, there are currently no service disruptions with the Explo platform and this is purely a Google Cloud issue.
Posted Jun 12, 2025 - 19:04 UTC

Identified

Although there isn't a formal note on their status page yet, many folks are reporting issues with Google Cloud here: https://downdetector.com/status/google-cloud/

This is an issue with Google Cloud / BigQuery and not Explo.
Posted Jun 12, 2025 - 18:20 UTC

Investigating

We have noticed an issue with BigQuery data sources. We are investigating.

Google has not updated their status page yet to declare an incident, but we are tracking potential issues on their end.
Posted Jun 12, 2025 - 18:16 UTC
This incident affected: Legacy Query Infrastructure (Customer Data Access) and Data Connector Infrastructure (Customer Data Access).