Scheduled Emails Not Sending

Incident Report for Explo Status

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 18:04 UTC

Investigating

We are currently investigating email deliverability issues
Posted Feb 05, 2026 - 17:49 UTC
This incident affected: Exports: Email delivery.