Global Explo outage due to CDN issues (reopened)

Incident Report for Explo Status

Resolved

From the Cloudflare team: "Cloudflare services are currently operating normally. We are no longer observing elevated errors or latency across the network."

We are marking this as resolved.
Posted Nov 18, 2025 - 18:42 UTC

Monitoring

Cloudflare has not marked the issue as follow resolved and has indicated a fix has been shipped and they are monitoring. We are going to re-open this in the monitoring state as well.

Previous Explo incident: https://status.explo.co/incidents/7tstjsfrkgwp
Cloudflare status: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 15:41 UTC
This incident affected: Explo Dashboards, Explo Report Builder, Exports: Email delivery, Exports: Image and PDF format, GovCloud Data Connector, Legacy Query Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports), and Data Connector Infrastructure (Customer Data Access, Dashboard Embeds, Report Builder Embeds, Tabular Exports).